Pré-requisitos de Configurações

SISTEMA OPERACIONAL

O PJe é suportado pela equipe do TRT quando utilizado em sistemas operacionais Windows 7 ou Windows 10.

As instalações em sistemas Linux, inclusive MacOS (Apple), não possuem suporte, apesar de termos a intenção de manter disponíveis no site do TRT15 manuais de instalação e configuração para os que desejarem instalá-los por sua própria conta.

NAVEGADOR

O navegador recomendado para uso com o sistema PJe é o Mozilla Firefox, instalado na última versão disponível. O navegador Google Chrome tem sido igualmente utilizado sem problemas, também na última versão disponível. Ambos são suportados pela equipe técnica do sistema através das plataformas de atendimento.

Não use o "Navegador PJe", iniciativa descontinuada há mais de 2 anos. A última versão disponível desta iniciativa já se encontra muito defasada e apresenta problemas com diversas funcionalidades do sistema PJe. A própria página do Navegador PJe já decretou seu fim, conforme se verifica em http://www.pje.jus.br/wiki/index.php/Navegador_Firefox_Portal_PJe. Recomenda-se a desinstalação do "Navegador PJe".

Já a utilização do "PJe Portable" deve ser feita conforme as instruções e orientações contidas no site do TRT4, mantenedor da solução. Para acessá-la, utilize a opção Configuração do Computador no endereço do link. A utilização do "PJe Portable" não possui suporte através do TRT15, mas tão somente aos navegadores recomendados acima, nas versões mais atuais disponíveis.

CERTIFICADO DIGITAL

Como o sistema PJe é acessado e utilizado através de certificação digital, é importante que seu certificado digital esteja bem instalado e configurado. Isso inclui a instalação da cadeia de certificação digital e dos drivers necessários ao funcionamento de seu certificado digital.

Para garantir o bom funcionamento de seu certificado digital, siga os 3 passos a seguir:

  1. Verifique que não existam certificados digitais expirados em seu token, seguindo o passo a passo disponível em https://trt15.jus.br/pje/certificado-renovado;
  2. Instale a cadeia completa de certificados digitais, o que garante ao sistema que seu certificado digital é válido e confiável, clicando no botão vermelho onde diz Usuário de Mozilla Firefox, lendo com cuidado e seguindo as instruções do endereço https://www.trt15.jus.br/programas/certificadodigital. Você pode ao final verificar que sua cadeia de certificados está completa, se desejar;
  3. Se o seu certificado digital for do tipo token, semelhante a um pen drive, instale o programa gerenciador de seu token e os drivers correspondentes clicando aqui e selecionando o token que corresponde ao seu. Se o seu certificado digital for armazenado num cartão, você precisará primeiro instalar os drivers do leitor de seu cartão, e depois ainda instalar os drivers correspondentes ao seu cartão. Para esta instalação, escolha o driver que tenha o chip com o desenho que corresponda ao do seu cartão.

A versão atual dos assinadores aceitos pelo sistema PJe não é compatível com certificados digitais hospedados em nuvem.

ASSINADOR

Na versão atual, o sistema PJe é compatível com as últimas versões dos assinadores Shodö e PJeOffice. É necessário certificar-se que a versão instalada destes assinadores está bem atualizada para evitar problemas ao utilizá-los.

Para instalar e configurar o Shodö em sua versão mais atualizada, siga este link.

Para utilizar o assinador PJeOffice, que foi recentemente atualizado para torná-lo novamente compatível com o PJe, use este link.

É possível escolher apenas um dos assinadores e usá-lo, ou instalar e utilizar ambos, dependendo da situação, mas é bom lembrar que este componente deve ser constantemente atualizado para garantir o bom funcionamento do sistema.

OBSERVAÇÃO FINAL

Caso após estas instalações e configurações ainda ocorra erro no acesso ou funcionamento do sistema, antes de contatar o suporte ao PJe, verifique se o erro já não está listado em nossa página de Dúvidas Frequentes.

Na tela de login do sistema PJe, no menu disponível no canto superior direito (as 3 barrinhas horizontais) existe a opção Pré-requisitos do sistema. Procuramos nesta página detalhar melhor os requisitos listados ali, mantendo-os tão atualizados quanto possível.